Fandom

The Elder Scrolls Wiki

Racial Compatibility - compatibility with other mods improved

1,148このwikiの
ページ数
新しいページをつくる
コメント0 シェアする
Bethesda-creation-kit.pngRacial Compatibility - compatibility with other mods improved
タイプ カスタム種族、互換性mod
Description カスタム種族 (追加種族) ModVampire との互換性を持たせる
バージョン 1.5
製作者 himika (ひみか)
Download
Racial Compatibility - compatibility with other mods improved (Skyrim Nexus)
有用なリンク
SkyrimのMod使用法
·

Racial Compatibility - compatibility with other mods improved とは、Creating a Playable Race - The right way を改良したmod。Dawnguard対応やバグ修正がされている。このmodの開発者は日本人。

原作MODは、ほとんどのカスタム種族 (追加種族) Mod に搭載されており、追加種族のVampire化、髪などのヘッドパーツの追加、クエスト進行上のバグ対策を行なっている。

Creating a Playable Race - The right way との違い 編集

オリジナルの RaceCompatibility.esm (Creating a Playable Race - The right way) との間の違い: PlayerVampireQuestScript.pex や CompanionsHouseKeppingScript.pex などのスクリプトを上書きしないため、これらの .pex ファイルを上書きする mod とより高い互換性を実現している。 (例えば、UFO - Ultimate Follower OverhaulBetter VampiresVampiric Thirst。) いままでこれらの mod は RaceCompatibility.esm と併用することが出来なかった。

また、ウッドエルフを使っていた場合にバンパイアやウェアウルフの変身が正しく行われていなかった不具合、バニラ種族のバンパイアを使っていた場合にDark Brotherhoodのクエストが進行不可能になっていた不具合も修正されている。

The Elder Scrolls V: Dawnguard だけでなく、これは The Elder Scrolls V: Dawnguard をインストールしていない環境でも働く。

互換性の例 編集

インストール 編集

  1. アーカイブ中の Data フォルダを、skyrim/Dataフォルダにコピーする。
  2. Unofficial Skyrim Patchを入れている場合は、option for USKP user フォルダもコピーする。
  3. 以下の pex ファイルのサイズが以下のサイズと一致する場合に削除する。ファイルサイズが一致しない場合は他の mod が使っている可能性があるので削除しないこと。以下の3つのファイルは Creating a Playable Race - The right way でインストールするファイル。
パス 削除するときのファイルサイズ CRC32
Data\Scripts\CompanionsHouseKeepingScript.pex 28,504 バイト BB8F5900[1]
Data\Scripts\PlayerVampireQuestScript.pex 12,622 バイト A7DA00B5
Data\Scripts\PlayerWerewolfChangeScript.pex 12,475 バイト A7BF0A01

また、modの競合をゲーム内で検知する機能がある。もし競合が発生している旨のメッセージが表示された場合は、メッセージに指定されたスクリプトを削除し、競合していると思われるmodを再度インストールすると良い。

RaceCompatibility for Dawnguard との違い 編集

類似MODの RaceCompatibility for Dawnguard とは、互換性実現のためのアプローチ方法が違うだけで、機能的に大きな差は無い。好きな方を選ぶと良い。

RaceCompatibility for Dawnguardは「競合しているスクリプトを書き換えて、RaceCompatiblity.esmと競合MODの双方が動くようにしよう」というアプローチ。競合MODの1つ1つに丁寧にパッチを当てることで互換性を実現している。対応MODは UFOUnofficial Skyrim PatchBetter VampiresVampiric Thirstは対応していないため、競合する。

当MOD は、「競合原因のスクリプトを使わないようにし、競合の原因自体をなくそう」というアプローチ。いまのところ競合をおこすMODは報告されていない。将来競合するかもしれない未知のMODにも強いと見ている。ただし、若干トリッキーな方法を使って競合スクリプトを排除しているため、 MODによっては競合する可能性がある。

RaceCompatibility for Dawnguardで正式に対応されているMODを使うのであれば、きっちりと修正がしてあるぶん、そちらを使った方が安全確実ではある。 他にも競合しそうなMODを入れている場合は、このMODを使ったほうが良いかもしれない。

互換性 編集

関連項目 編集

参考文献 編集

外部リンク 編集

広告ブロッカーが検出されました。


広告収入で運営されている無料サイトWikiaでは、このたび広告ブロッカーをご利用の方向けの変更が加わりました。

広告ブロッカーが改変されている場合、Wikiaにアクセスしていただくことができなくなっています。カスタム広告ブロッカーを解除してご利用ください。

Fandomでも見てみる

おまかせWiki